Issue with configuration parameters for deployed workflows

Issue with configuration parameters for deployed workflows

Summary:

This is a bug in AEUI 5.3.0 regarding workflow edit operation because of which you're facing this issue. It has already been found and fixed in AE release 5.5.0.

Root cause: 

When you enable the Email notification feature for a particular workflow without giving any values for the ""By Email"" field and save, the next time you try to edit the same workflow, you will not see the configuration parameters in AEUI (this is a bug) and now if you save that workflow, the parameters will get updated with null values (that means no parameters) in the database, which is what exactly happened in your case.

Workaround:

1: Create a new workflow and don't enable the email notification feature and if you do enable it then make sure you provide at least one email address in the "By Email" field.
2: Edit existing workflow,
-- disable/uncheck notification feature or provide at least one email address in "By Email" field
-- save it
-- and after that update the workflow by importing a new zip file having expected configuration parameters. 

Fix:

Please upgrade AE to 5.5 version.


      Links to better reach 

            Bot Store

             EPD